Browser plugins don't work?

Have some questions or having issues with your DVR/NVR(s), Post them here for the mods and other users to assist you with.
markplewis
Posts: 45
Joined: Fri Sep 02, 2016 12:41 pm

Re: Browser plugins don't work?

Postby markplewis » Sat Jan 06, 2018 10:39 am

grabczb wrote:^
What can we do collectively as customers to bring this up to Amcrest as a priority?


Probably nothing. It's obvious Amcrest has absolutely no concern for their customers and is quite comfortable telling outright lies about a fix being imminent. The best we can do is continue to leave 1-star reviews on Amazon and other forums, and note in the comments the company is completely untrustworthy.

I realize it's not an option for most people, but I am in the processes of replacing every Amcrest product I own.

lloyd966
Posts: 2
Joined: Sun Jan 07, 2018 8:18 am

Re: Browser plugins don't work?

Postby lloyd966 » Sun Jan 07, 2018 8:42 am

I was able to get the Amcrest Web View to work with the latest version of Chrome.

I installed the following apps from the Chrome Web Store

- Amcrest Web View

- NACL Web Plug-in

The trick is not to access the Web Viewer by opening an new tab and typing in the IP address of your camera,

But

by first opening a tab for the Chrome web apps (Ie: chrome://apps/) and then click on the Amcrest Web View Icon.

A new window will open up and you now need to enter the IP address of your camera in the box ("Search or type URL)
and press return or the Go button. A new screen will be displayed in the window and you then enter your username and password and click the Login Button. Takes a few seconds and your camera will be displayed. Make sure that the Live Button is selected.

Hope this helps. :D :D :D :D

james_s
Posts: 15
Joined: Fri Dec 29, 2017 2:54 am

Re: Browser plugins don't work?

Postby james_s » Tue Jan 09, 2018 3:02 am

Have you found a NVR that does support modern browsers without ridiculous workarounds? I've been looking around and they all seem to run the same ancient firmware with minor customizations to the interface.

If one of these companies open-sourced their firmware, competent developers would rapidly improve upon it and they would take the market by storm as happened with broadband routers and DD-WRT and Tomato firmware.

Rblaze
Posts: 1
Joined: Mon Sep 25, 2017 7:02 am

Re: Browser plugins don't work?

Postby Rblaze » Tue Jan 09, 2018 6:54 pm

Why is it when I click on the IP Config web plug in I get a link to Google Chrome ?https://chrome.google.com/webstore/detail/nacl-web-plug-in/pbdcmagkbhnjpjlnpibbmggikpedpilc

It also does not work?

gammy999
Posts: 39
Joined: Thu Dec 07, 2017 10:56 am

Re: Browser plugins don't work?

Postby gammy999 » Thu Jan 11, 2018 11:17 am

Anyone have this working..if so, what browsers, etc;..any instructions...?

kenkadish
Posts: 6
Joined: Thu Nov 30, 2017 3:58 pm

Re: Browser plugins don't work?

Postby kenkadish » Wed Feb 21, 2018 3:17 pm

So I have been having a strange problem using Amcrest live view, and now have a solution I wanted to share.

I can access live view on
Amcrest Cloud IE11
Desktop (win 10), IE 11
very older laptop (XP), all using Internet Explorer,

Ipad,
Samsung S8
Google Chrome, but the plugin does not integrate, and it is a pain.

It just will not work with IE 11 on my win 10 laptop. Firewall on or off, safe mode on or off, active X controls all enabled, active X disabled. However, it does work fine with Surveillance Pro???

Spent some time with tech support, and had them remote to me, but no joy.

I have loaded and reloaded the IE plugin a thousand times, and it shows running, but still no live picture in IE.

The solution?

I installed Sea Monkey browser, and that was it....works great!

Hope this helps someone out.

Ken

John94si
Posts: 29
Joined: Mon Jun 05, 2017 6:59 pm

Re: Browser plugins don't work?

Postby John94si » Thu Feb 22, 2018 9:00 am

kenkadish wrote:The solution?

I installed Sea Monkey browser, and that was it....works great!

Hope this helps someone out.

Ken



THANK YOU.. this works for me finally and no plugin install required.. Support tried yesterday on IE and couldnt get it to work.. they should tell people to try seamonkey.

https://www.seamonkey-project.org/releases/#2.49.2

sprime1
Posts: 10
Joined: Sat Jan 02, 2016 11:30 am

Re: Browser plugins don't work?

Postby sprime1 » Thu Feb 22, 2018 11:48 am

Use this plugin for IExplorer compatibility in Chrome

https://chrome.google.com/webstore/deta ... mmjbdenadd

donb007
Posts: 1
Joined: Sun Mar 04, 2018 10:52 am

Re: Browser plugins don't work?

Postby donb007 » Sun Mar 04, 2018 11:10 am

The quickest solution for me was to simply download an older version of Firefox. Sure, it doesn't have the latest security patches, but I'm not surfing the web with it - I only use it for my cameras - and it works like a charm.
I use version 39.0, because I seem to recall testing v50.0 and it didn't work. I believe they were already phasing out support for NPAPI.... but there's plenty of versions to try off the main branch:
https://ftp.mozilla.org/pub/firefox/releases/
Here is version 39.0.
https://ftp.mozilla.org/pub/firefox/releases/39.0/win32/en-US/

Enjoy!

martin777
Posts: 14
Joined: Mon Jan 01, 2018 5:10 pm

Re: Browser plugins don't work?

Postby martin777 » Wed May 30, 2018 7:00 pm

For 2 weeks I've been using Firefox ESR 52.8.0 (32bit) in Win7 and it works very well
on my Amcrest 848E, 853E and 858 cameras.
Maybe I'll try SeaMonkey on my Linux Mint 17.2 box.
I just talked to Amcrest support and was re-assured their developers
were working on the browser SNAFU.
Yea, Right. :twisted:

T.Williams
OKC
IP2M-842E,848E,853E,858W (all PoE), 841B, 841W WiFi


Return to “NVRs / DVRs”

Who is online

Users browsing this forum: No registered users and 1 guest