HELP: Amcrest 960H DVR & Hard Reset stopped working

Have some questions or having issues with your DVR/NVR(s), Post them here for the mods and other users to assist you with.
geode
Posts: 2
Joined: Sat Jan 26, 2019 7:46 pm

HELP: Amcrest 960H DVR & Hard Reset stopped working

Postby geode » Sun Jan 27, 2019 9:35 am

Hi all,

My DVR has been working fine for the past 2.5 years.

[Potentially relevant information: About 3 weeks ago, I tried playing back some recorded files but received the message "File not found", which was odd. I've been trying to figure this issue out.]

This evening, I realised that there was a small black Logitech item inserted in the front USB port. It looks like a nano receiver for a wireless mouse — due to poor memory, I can't accurately confirm what this USB item is. I pulled it out, Amcrest system was still working.

When I walked by the system 1hr later, the monitor screen was in standby mode, apparently not receiving any signal from the DVR. The screens on the Amcrest phone app show the text "Open failed".

I've tried removing and reattaching the DVR power cord.
The green power light in front is glowing steadily. The HDD light is off.
There doesn't seem to be any odd noises coming from the DVR.

I've tried opening up the DVR and performing a hard reset but there's no response or noise when I press and hold down the button.


Any suggestions on how to troubleshoot/fix :?:
Thanks in advance.

Melvin
Site Admin
Posts: 2240
Joined: Wed Oct 14, 2015 2:20 pm

Re: HELP: Amcrest 960H DVR & Hard Reset stopped working

Postby Melvin » Sun Jan 27, 2019 4:31 pm

Hi geode ,

Did you try with different power adopter? and also remove the HDD try to do hard reset.
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image

geode
Posts: 2
Joined: Sat Jan 26, 2019 7:46 pm

Re: HELP: Amcrest 960H DVR & Hard Reset stopped working

Postby geode » Mon Jan 28, 2019 3:48 am

Hi Melvin,

Thanks very much for your response.

I'll try using a different power adapter.

As mentioned, I tried doing a hard reset but there was no response at all.
Just to clarify: Do you mean to completely remove the HDD, leave the power cable in and do a hard reset?

Cheers

Joel
Posts: 1
Joined: Wed May 01, 2019 11:51 am

Re: HELP: Amcrest 960H DVR & Hard Reset stopped working

Postby Joel » Wed May 01, 2019 11:57 am

Hi Geode,

Could you fix your DVR? i have the same situation

User avatar
James.S
Site Admin
Posts: 134
Joined: Thu May 28, 2015 3:40 pm

Re: HELP: Amcrest 960H DVR & Hard Reset stopped working

Postby James.S » Wed May 01, 2019 12:10 pm

Joel wrote:Hi Geode,

Could you fix your DVR? I have the same situation



This is definitely a particularly weird situation with your device.

Please Reach out to our support team so we can work with you directly. ([email protected])
Image
If you have any more questions or concerns about this product or other Amcrest products, please reach out to us at [email protected].

- James.S


Return to “NVRs / DVRs”

Who is online

Users browsing this forum: No registered users and 3 guests