GMail setup - test email fails

Have some questions or having issues with your DVR/NVR(s), Post them here for the mods and other users to assist you with.
RegisterToSearch
Posts: 2
Joined: Thu Jan 18, 2018 5:19 pm

GMail setup - test email fails

Postby RegisterToSearch » Wed May 29, 2019 7:08 pm

I'm using a GMail account to send emails out of my home automation system and it works fine.

When I try to set up my Amcrest NVR up with exactly the same settings, I get a "Test email failed" error when I press the "Email Test".

I don't see any way to look at logs to see what error is occurring.

SMTP Server: smtp.gmail.com
Port: 587

Encrypt Type: TLS

Both my NVR and home automation system are on the same subnet and thus use the same exit path through the firewall so that's not the issue. I'm an IT consultant and one thing I get paid to do is to set up pfSense firewalls so I'm fairly certain the firewall is not causing problems.

per this:
https://support.amcrest.com/hc/en-us/ar ... lerts-NVR-


I have 2-Step Verification turned off on Google and I have "Less secure app access" turned on.

I'm kind of stuck here without being able to look at the SMTP logs to see what error is happening.

Thanks,
Sam

RegisterToSearch
Posts: 2
Joined: Thu Jan 18, 2018 5:19 pm

Re: GMail setup - test email fails

Postby RegisterToSearch » Fri May 31, 2019 2:37 pm

A couple of other things that would be helpful to try to diagnose issues like this:
* DNS resolution tester
* Ping utility

shaywood
Posts: 3
Joined: Sat Jun 15, 2019 11:47 am

Re: GMail setup - test email fails

Postby shaywood » Sat Jun 15, 2019 11:51 am

Folks on other forums are reporting that Google made changes to their email system which is conflicting with the Amcrest and other camera email settings. I have 2 cameras and an NVR that can't send Gmail SMTP emails since June 6th. Hopefully there is a fix?

User avatar
Revo2Maxx
Posts: 112
Joined: Sat Jun 15, 2019 3:05 pm

Re: GMail setup - test email fails

Postby Revo2Maxx » Sat Jun 15, 2019 8:08 pm

Sadly isn't something that Amcrest or other can fix it is a Conflict with Gmail. I used it as well. Looking over Gmail today there is some major things they changed. Even though it says I can still send. I even changed my google password and then made the changes in my CMS, IPM, 960H, CVI dvrs and all fail to send emails. Even tried changing to TSL in the units that will work with it and still fails.... It is almost like they are trying to make use send only to Gmail accounts. I have upgrade Good account so I don't understand why. My account I changed from 15gb storage to a 1TB storage account and still having issues. Like I said even changed my Passwords on all devices after updating password on google still no go... Whats next...
A Lie is a Lie, no matter how big or Small. The Truth will set you Free
Secure you & your Future be Safe

James

sD7a5
Posts: 3
Joined: Sat Oct 28, 2017 11:12 am

Re: GMail setup - test email fails

Postby sD7a5 » Mon Jun 17, 2019 3:52 pm

Google is blocking. I setup and Outlook.com profile, and they are doing the same after only a day or two.

plusfour
Posts: 55
Joined: Tue Mar 06, 2018 4:04 am

Re: GMail setup - test email fails

Postby plusfour » Tue Jun 18, 2019 10:49 pm

Google have had one of their periodic "let's change everything at random for no reason" brain seizures, which has broken Gmail for things like this. There's a long, long thread over in the cameras forum that goes into this in some detail. Quick solution, switch to something like Outlook. Long-term solution, Amcrest are working on firmware updates, but this may only be for cameras. In any case since Google can change things at random again at any point, a more reliable long-term solution is to migrate off Gmail onto a less unstable mail host.

plusfour
Posts: 55
Joined: Tue Mar 06, 2018 4:04 am

Re: GMail setup - test email fails

Postby plusfour » Tue Jun 18, 2019 10:59 pm

sD7a5 wrote:Google is blocking. I setup and Outlook.com profile, and they are doing the same after only a day or two.


Hmm, if it takes a day or two that may mean my use of Outlook will run into problems as well. So far after nearly 24 hours it's still working. If anyone can recommend a mail provider that works, and that doesn't change their setup at random like Google do, it'd be good to know. I've already tried GMX but can't send through them, unfortunately since the Amcrest UI displays no info apart from "failed" I can't tell why. There's always Yandex, but I'm not sure I want to send my security alerts via Russia...


Return to “NVRs / DVRs”

Who is online

Users browsing this forum: No registered users and 1 guest