Browser plugins don't work?

Have some questions or having issues with your DVR/NVR(s), Post them here for the mods and other users to assist you with.
raylo
Posts: 4
Joined: Fri Jun 03, 2016 7:04 am

Browser plugins don't work?

Postby raylo » Fri Jun 03, 2016 7:12 am

Cam is the Amcrest IP2M-844 outdoor POE dome

New to Amcrest but using IP cams for over 10 years and never seen anything like this. Neither Chrome nor Edge browsers stream the video once I am logged in even after I have clicked "install the plugin" and have run the webplugin.exe files and clicked yes on the Windows prompt. I have tried multiple times and even restarted the browsers and computer. The message to "please click here to install the plugin" never goes away?? This is a Win 10 machine, BTW. I saw some threads from 2015 when the old plugin stopped working when Chrome dropped NAPI support. But surely that should have been fixed by now with new plugins?? This should not be hard.

Edit: I tried another PC, same issue. I also tried Safari on my iPhone, same issue. Camera is going back to Amazon.

raylo
Posts: 4
Joined: Fri Jun 03, 2016 7:04 am

Re: Browser plugins don't work?

Postby raylo » Fri Jun 03, 2016 9:27 am

OK, I spoke to tech support and we got it working by opening up an Internet Explorer window in Edge browser. Seriously, is that the only way to access these cams via web browser? Is there firmware coming that will allow the cams to work with modern browsers? I can't see MS continuing support for IE, even in emulation mode, for too long. Then what? Still deciding what to do with the cam. The hardware looks nice and the daytime pic is good. And I intend to run it on my Blue Iris server so once setup I shouldn't need the web interface much, but you never know.

What is everyone else doing for browsers?

lmm
Posts: 45
Joined: Sat Mar 19, 2016 12:47 am

Re: Browser plugins don't work?

Postby lmm » Fri Jun 03, 2016 10:25 am

have to use IE when using the web.

i only use the web to play with the configuration which you can do without the plugin.

otherwise, i do all my viewing using the Tinycam app.

Albert
Site Admin
Posts: 33
Joined: Wed Jan 20, 2016 9:55 am

Re: Browser plugins don't work?

Postby Albert » Sat Jun 04, 2016 9:18 am

Hi there,

We recommend the Internet Explorer or the Mozilla Firefox for a windows computer. The plugins are not compatible with Edge browser yet. But it will work with Google Chrome browser if you install the Amcrest Web View app for Google Chrome. You can get it from here: https://chrome.google.com/webstore/detail/amcrest-web-view/oddndbjhpcpopbebhonolceinkbnheih

After installing Web View open the app and enter the IP address of the camera to address bar. It will definitely work.

For mobile devices like iPhone or iPad please use our official application Amcrest View Pro/Lite.
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image

GreenScrew
Posts: 39
Joined: Fri May 13, 2016 2:55 pm

Re: Browser plugins don't work?

Postby GreenScrew » Mon Jun 06, 2016 9:22 pm

You can also access the live stream without the browser plugin through amcrestcloud.com if you've set it up there. This is the Amcrest cloud services site, the free service only supports 4 hours of recorded event retention and I believe there is a limited amount of live viewing (though (I've never run out so far). This works in Edge (and I'd assume all other browsers as well). There are also a few (limited) number of camera options that can be configured here such as IR mode. It uses Flash. Hopefully when the upcoming annual update comes for Windows 10 and Edge allows plug-ins Amcrest will develop one for Edge. But hopefully you can understand the predicament that Edge doesn't currently support plug-ins and for the controls and functionality of Amcrest View you need one.

Mildew
Posts: 47
Joined: Tue May 31, 2016 8:03 am

Re: Browser plugins don't work?

Postby Mildew » Tue Jun 07, 2016 7:01 am

I had a problem with the plugin with Firefox and an 842 camera. I called technical support and they suggested that I uninstall and then reinstall the plugin. I have not had a chance to try that yet.

[email protected]
Posts: 3
Joined: Mon Jul 18, 2016 11:25 am

Re: Browser plugins don't work?

Postby [email protected] » Mon Jul 18, 2016 11:43 am

Same problem here. Chrome, Firefox, IE, all do not work with a live view. All plugins installed. Tried on both MAC and PC. I can access the setup screen with the browsers, but not the live view. I don't have any trouble using IP Camviewer lite from an ipad or Android, so I know my IP settings and home firewall are OK. The browser support for these devices is awful. IP2M-842

alrubaa
Posts: 3
Joined: Mon Jul 18, 2016 12:40 pm

Re: Browser plugins don't work?

Postby alrubaa » Mon Jul 18, 2016 12:59 pm

Hi All,
I am stuck as well with browser plugin issues, but I also noticed a strange behaviour with 2 different Amcrest cameras. Basically I bought 2 Amcrest cameras, the proHD IP2M-841 POE and the bullet external camera IP2M-842 POE. As per instructions I installed Chrome (version 51) on windows 10 PC and then I installed the Amcrest web view app. The proHD works fine within chrome only. However, using the same PC, same settings and same Chrome browser the plugin does not work with the bullet camera (IP2M-842). I upgraded the firmware for the IP2M-842 but to no avail. I have tried re-starting the computer, re-installed Chrome and plugin, ran it through desktop shortcut or through chrome\\apps, same results. Every time I plugin the proHD the plugin works straight away, and every time I plugin the bullet camera all I get is the message click here to install the plugin and nothing happens whatever I do.

Both cameras work fine with Amcrest surveillance pro.

It is just that the bullet camera refuses to work with any browser. this must be an issue with that particular model (God knows how many other models are affected) and surely Amcrest must be aware. Any one got the bullet camera working with Chrome?
I would appreciate the help.

disgustipated
Posts: 18
Joined: Sat Dec 31, 2016 5:57 pm

Re: Browser plugins don't work?

Postby disgustipated » Sat Jan 14, 2017 6:09 pm

I had the same thing, i think... got failed to load plugin when i logged into the bullet ipm-722s. I was using the dns name, when i used the ip itself it seemed to work fine. i also have one of the 1080p wifi cams and it doesnt have this issue, also some differences in the options available in the web config... why... just make all your cams the same.

WolfLead6
Posts: 3
Joined: Thu Feb 02, 2017 9:28 am

Re: Browser plugins don't work?

Postby WolfLead6 » Tue Apr 25, 2017 10:25 am

Albert wrote:Hi there,
We recommend the Internet Explorer or the Mozilla Firefox for a windows computer. The plugins are not compatible with Edge browser yet. But it will work with Google Chrome browser if you install the Amcrest Web View app for Google Chrome. You can get it from here: https://chrome.google.com/webstore/detail/amcrest-web-view/oddndbjhpcpopbebhonolceinkbnheih
After installing Web View open the app and enter the IP address of the camera to address bar. It will definitely work.
For mobile devices like iPhone or iPad please use our official application Amcrest View Pro/Lite.



Will definitely NOT work with latest FireFox. Installed the webplugin and it still will not open the live view. The "Please click here to download and install the plug-in." box never goes away. So far have been only able to get it to work in IE.


Return to “NVRs / DVRs”

Who is online

Users browsing this forum: No registered users and 2 guests