Unplayable mp4 files

Have some questions or having issues with your IP Camera(s), Post them here for the mods and other users to assist you with.
ElBrewski
Posts: 7
Joined: Thu Nov 10, 2016 10:09 am

Unplayable mp4 files

Post by ElBrewski »

Hi,
I have the Amcrest ProHD Outdoor 1080p WiFi (842 I believe) and have it set up to FTP video files to my NAS. About half of the files are not playable with any video player on my system (Windows 10) and also on my Android tablet. The players give an error usually saying the file is either using an encoder they don't support or that the file is corrupt.
A lot of the files play just fine. I have tried different resolutions and get the same result.

Anyone else seen this issue?
Thanks
Melvin
Site Admin
Posts: 2238
Joined: Wed Oct 14, 2015 2:20 pm

Re: Unplayable mp4 files

Post by Melvin »

Hello ElBrewski,

Can you check if the unplayable files have an '_' at the end? If that is the case, renaming it without the '_' will make it playable. I understand this is not a acceptable solution. We have seen this issue with some servers-devices and are working on it.
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image
ElBrewski
Posts: 7
Joined: Thu Nov 10, 2016 10:09 am

Re: Unplayable mp4 files

Post by ElBrewski »

Hi Melvin,
I have seen files with the underscore but not able to find any now. Anyway this does not seem to be my issue. My test this morning showed 2 out of 4 files are not playable. This is not good.

I have another brand of camera that FTPs .avi files to my NAS with no problems, and two other brands that just send .jpgs.
I can provide files for analysis if that would help.
Thanks
-Larry
ElBrewski
Posts: 7
Joined: Thu Nov 10, 2016 10:09 am

Re: Unplayable mp4 files

Post by ElBrewski »

Hi Melvin,
I have seen files with the underscore but not able to find any now. Anyway this does not seem to be my issue. My test this morning showed 2 out of 4 files are not playable. This is not good.

I have another brand of camera that FTPs avi files to my NAS with no problems, and two other brands that just send jpgs.
I can provide files for analysis if that would help.
Thanks
-Larry
ElBrewski
Posts: 7
Joined: Thu Nov 10, 2016 10:09 am

Re: Unplayable mp4 files

Post by ElBrewski »

Hi, (I'm having trouble submitting a response, trying again. Sorry if multiple responses show up)
The problem files do not have the underscore at the end. I can provide example files if that would help.

fyi I do have other camera brands that save files on my NAS without this issue.
Thanks!
PeZzy
Posts: 25
Joined: Sat Mar 05, 2016 5:10 pm

Re: Unplayable mp4 files

Post by PeZzy »

I have found that the recent update which now uses mp4 files does seem to create unreadable files over mediocre Wifi connections. It was less of a problem with dav files. You might try using a Wifi app on your cellphone/tablet near the camera to scan for other Wifi routers in the area, then switch your router to a channel that's not being used. I use an app called "Wifi Analyzer" on my Android phone.
ElBrewski
Posts: 7
Joined: Thu Nov 10, 2016 10:09 am

Re: Unplayable mp4 files

Post by ElBrewski »

It does appear to be a bandwidth problem. I experimented with using a Wifi bridge on the inside of my garage and connecting direct Ethernet to the camera and it seems to work much better.

The bridge is a Western Digital AC wifi (no longer in production) that I happen to have as a spare. My router is a TP-Link AC 1750 class.
Melvin
Site Admin
Posts: 2238
Joined: Wed Oct 14, 2015 2:20 pm

Re: Unplayable mp4 files

Post by Melvin »

Hello ElBrewski,

In that case the poor wifi signal might be causing the issue. It might be causing the camera to write incomplete files. So leaving it hardwired might be a better choice in your case if possible.
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image
ozherelyev
Posts: 5
Joined: Thu Oct 13, 2016 4:28 pm

Re: Unplayable mp4 files

Post by ozherelyev »

I have same annoying issue with half of my files get uploaded with xxx_ names. Renaming them to xxx (with out _) don't make them readable!
Please fix FTP recording! Use some sort of redundancy, repeat record attempt, use SD card as a buffer etc. Just make sure the file get uploaded correctly! It's major functionality which must work.
Melvin
Site Admin
Posts: 2238
Joined: Wed Oct 14, 2015 2:20 pm

Re: Unplayable mp4 files

Post by Melvin »

Hello ozherelyev,

Sorry to hear about the trouble. We will keep our R&D team posted on this issue.
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image
Post Reply