IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Have some questions or having issues with your IP Camera(s), Post them here for the mods and other users to assist you with.
maxbraketorque
Posts: 7
Joined: Tue Dec 20, 2016 8:44 am

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by maxbraketorque »

When I received emails about new plug-in free FW, I was very excited to soon have a FW that didn't require an outdated plugin or partially functional Amcrest webview app in Chrome, but after stumbling on this thread, I think I'll stick with the old FW for a while.
User avatar
Revo2Maxx
Site Admin
Posts: 2933
Joined: Sat Jun 15, 2019 3:05 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by Revo2Maxx »

There are Pros and cons to everything. I have to say that I wanted to know what was going on between the 2 FW so i have one with the new and one with the OLD and to be honest they both have the same feel and work on my DVR the same... Yes I have them on IP Ch of my DVR and both cameras look an feel the same in almost every aspect.

There are 2 things that kind of Drive me nuts... But strange thing is this don't happen every time...

1 On Weekly Reboot the camera gets off track of where it was facing and the Presets are all crazy. SO I have Presets 1-9 set. This week on the Reboot I didn't even know it had rebooted. Yet seen in logs.... That is because camera was facing same way and when I went between my Presets they were facing where I had them YAY a win this week. Last Week not same... Last week my camera after reboot woke up in full right face and all presets were somewhere other then where I had put them lol.

The second and kind of related. The Pan and Tilt of the NEW FW is kind of not easy to control. Even when Speed is set to 1. Camera all zoomed out still has feel like your zoomed in when trying to Pan or Tilt. While this is not every time there are times that the Fast press just moves as you would hope where the next fast press in any direction will make the camera move say if Panning it will take it maybe 240 degrees around on the same fast press of the arrow keys....

Other then that. The camera acts like the Old FM. Oh besides the 2 way talk don't work that that had something to do with a Security issue so other then that it is all good. Camera looks great in both FW so that is good...

Oh and one last thing not that is really matters but the Date and time displayed is little larger and Dot Matrix looking.

However someone that has never owned one the the older FW cameras This camera is Great and Functions as one would help. Keeping an eye on what you want to.
Try to Avoid CCA Networking Cables They are JUNK PERIOD!
Where there is Life there is Hope
James
cdavejump
Posts: 3
Joined: Wed Sep 04, 2019 5:17 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by cdavejump »

In addition to my problems mentioned before due to the latest firmware upgrade, I now have a problem this morning when I wanted to darken the display using "image adjust, then "brightness" my Hue colors are way out of whack. The greens are now purple!

On the PC "Amcrest Survelience Pro" software I have to go to Live “View” window, then right click on “Adjust”, then adjust “Hue” to 10-15 before it looks normal. I tried powering off and on, and also restarting thru the maintenance screen with no cure.

Amcrest customer support, PLEASE HELP! I own three of your cameras and used to really like them, now I want to go online and post horrific and truthful reviews based on the lack of support over these rogue units.

I am at my limit....Dave [email protected]
moosefist
Posts: 1
Joined: Tue Nov 19, 2019 12:29 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by moosefist »

I assume this firmware will not work on the IP3M-943 camera.

Is there an ETA for when that device will be updated?
User avatar
Revo2Maxx
Site Admin
Posts: 2933
Joined: Sat Jun 15, 2019 3:05 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by Revo2Maxx »

@moosefist Hello and Welcome to the Forum...

This firmware is only for the cameras listed in page 1.... Trying to do so to another camera may make it no longer work.

About a time frame. From what I have heard there is no idea yet of any other release dates. Once something is to a point of release they like to test out most of the function rather then just releasing something that may make something that did work no longer work... Also if they brick a Camera they might have the ability to fix it in ways we can't.. Besides an issue with maybe gmail not working is there a security issue that may need faster patch... Things take time...
Try to Avoid CCA Networking Cables They are JUNK PERIOD!
Where there is Life there is Hope
James
Intrigued
Posts: 9
Joined: Sun Jun 25, 2017 2:37 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by Intrigued »

Speaking of IP3M-943 and new/fixed firmwares. Nearly three months ago I contacted Amcrest regarding a security fix they implemented on IPM-721 (in particular, CVE-2017-8229) that also affects IP3M-943. Until this day I did not get an answer and in the last two and a half years no firmware was released for IP3M-943. Strange giving it is a popular product. Is there an intermediary here that can forward this matter to the Amcrest team? Thank you.
User avatar
Revo2Maxx
Site Admin
Posts: 2933
Joined: Sat Jun 15, 2019 3:05 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by Revo2Maxx »

@Intrigued

I am not 100% sure that is still the case for the camera... There was an update after that should have cleared that up.. Anyway I would guess that the Current 2017 FW had that issue removed because that was dated in 2016 firmware and there was new 2 times I know of for sure in 2017.. Sadly the FW is Mis-leading because of the 2.420 of the 721 and I am going to guess that the 943 has stayed with the 2.400 number for a while.... Sadly confusing even with the new FW for the Normal 841 went from 2.520 back to 2.420 and that was what was released in 2017 however the new one has the date showing in the FW number at the end but still would think maybe change to something so people know it is Java but looking at the start of the FW of both one might think they had the old if don't look at whole number... Since the start of the 841 there has been 12 total upgrades. The one updated today was 01 upgraded to 11 and that is the 2.520 version..
2.420.AC00.5.R, build:2015-07-29 <-----How it is listed
2.420.AC00.17.R, Build Date: 2017-03-22 <-----How it is listed
2.520.AC00.18.R, Build Date: 2017-06-29 <-----How it is listed
V2.420.AC00.18.R 8/3/19 <-----How it is listed and this one is Java Script

And looking at my Boxes I think I learned some things too lol... I have 2 Black and 1 White. Sadly my POE is dead and my son said he is sure he still has the box. It was bought for him some time ago started having some issues so we got him a new 2k one..
Ver.jpg
Ver.jpg (388.27 KiB) Viewed 2109 times
Try to Avoid CCA Networking Cables They are JUNK PERIOD!
Where there is Life there is Hope
James
eklee
Posts: 3
Joined: Sun Dec 15, 2019 2:07 am

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by eklee »

I just updated my IP3M-941 camera recently and I am having huge performance issues similar to the other users reporting. Camera is barely able to load a live feed and web interface is sluggish. Is there any plan or timeline for the next FW release to address the issues with the last update?
fox
Posts: 2
Joined: Tue Jul 23, 2019 12:56 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by fox »

:-( F
User avatar
Revo2Maxx
Site Admin
Posts: 2933
Joined: Sat Jun 15, 2019 3:05 pm

Re: IP3M-941/IP2M-841E/IP3M-HX2 Firmware Release

Post by Revo2Maxx »

@eklee
Hello and welcome to the Forum...

While I am not going to say this is the issue but have you tried to do another reboot after the update... Also a factory reset is a Expectation after FW update.... Also should Format your MSD...

This week my Camera;'s have been very unhappy with me... I with them lol... However it is my fault my cameras are not happy with me this week that is because even though I have them indoors They are enclosed in windows that are sealed and found they have fallen below the Normal Operating temp range and while they are working they are VERY slow and unhappy lol.... They were driving me crazy and Reset my cameras, My DVR's my PC-NVR, MY Servers and everything.. Then put a Temp Gauge in the area where they are sealed into and found they are VERY cold between 9 and 20 degrees F. When they are running above the 14 or -10c as they are designed to work they are fine...
Try to Avoid CCA Networking Cables They are JUNK PERIOD!
Where there is Life there is Hope
James
Post Reply