Gmail SMTP Setup Error

Have some questions or having issues with your IP Camera(s), Post them here for the mods and other users to assist you with.
emrekacan
Posts: 4
Joined: Thu Mar 03, 2016 2:23 pm

Gmail SMTP Setup Error

Postby emrekacan » Thu Mar 03, 2016 2:33 pm

Hi ,

I do not know how to speak English . "Google translate" and I translate into English
I could not mail the adjustment, it fails.


Image
Image
Image
Image

Melvin
Site Admin
Posts: 2238
Joined: Wed Oct 14, 2015 2:20 pm

Re: Gmail SMTP Setup Error

Postby Melvin » Thu Mar 03, 2016 2:56 pm

Hello emrekacan,

Please take a look at the suggestions on the below thread. Those settings are important specifically for Gmail.

post1601.html?hilit=less%20secure%20app&sid=f9d17e6762a61296ea91117d987cec75#p1601
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image

emrekacan
Posts: 4
Joined: Thu Mar 03, 2016 2:23 pm

Re: Gmail SMTP Setup Error

Postby emrekacan » Thu Mar 03, 2016 3:05 pm

"Hotmail" and "yahoo" I'm trying to give them in error

emrekacan
Posts: 4
Joined: Thu Mar 03, 2016 2:23 pm

Re: Gmail SMTP Setup Error

Postby emrekacan » Thu Mar 03, 2016 3:08 pm

I try now.
successful.
Thank you :)

emrekacan
Posts: 4
Joined: Thu Mar 03, 2016 2:23 pm

Re: Gmail SMTP Setup Error

Postby emrekacan » Thu Mar 03, 2016 3:47 pm

test mail arrived,but the alarm did not mail

Melvin
Site Admin
Posts: 2238
Joined: Wed Oct 14, 2015 2:20 pm

Re: Gmail SMTP Setup Error

Postby Melvin » Fri Mar 04, 2016 4:26 pm

Hello,
Please try the below suggestion make sure all the settings mentioned are the way it should be.

Thanks to Oendaril for the hint about adding the snapshot checkboxes. What I discovered was that I had unchecked the "Attachment" checkbox by "Subject" in SMTP(Email). I had just wanted a notification, I did not really want an attachment. However, Amcrest requires this snapshot/attachment checkboxes be enabled for it to send the email notification. I have to say, the snapshot is not very large in size and it does add value.

The final trick was that I had to try another email address. For some reason, the internal amcrest settings must have gotten confused for gmail. So even though test messages were getting through, the motion event email was not. So I temporarily set my email to my yahoo account. And voila, motion event emails started coming through. When I reset back to my original gmail account, voila, motion event emails started coming through.

Interesting to note. For both test emails and motion event emails, Yahoo has a 3 minute delay. Gmail is almost instantaneous.

These are the details of my settings.

Under Network>SMTP(Email)

update all fields appropriate to your email account
for gmail, I used smtp.gmail.com,465,<username>@gmail.com,<mypassword>,<username>@gmail.com,SSL,<Home Amcrest Motion Alert> for subject
I had to check the Attachment box, apparently this is tightly coupled to requiring the snapshot checkbox being set as well
I could not get the email notification to work until I checked this attachment box
I also added 2 recipient emails
I did not enable the Keep Alive checkbox


Under Event>Video Detection

I enabled Schedule and Setup my desired time ranges
I set my detection area
I selected both the "Send Email" and the "Snapshot" checkboxes
per Oendaril's hint, I knew I had to set this "Snaphot" checkbox too
I left the other fields defaulted to their factory values


Under Storage>Schedule

I made sure that both the "Record Schedule" and "Snapshot Schedule" were aligned with the times that I wanted to detect motion events
For me, I just left the factory defaults of storage available 24/7
I control the motion event collection times through the Event>Video Detection
Can't find your answer on the forum? Try our Knowledge Base! https://amcrest.zendesk.com/hc/en-us

Image

creiglee
Posts: 1
Joined: Tue Mar 20, 2018 12:34 am

Re: Gmail SMTP Setup Error

Postby creiglee » Tue Mar 20, 2018 12:36 am

It is because Google blocks sign-in attempts from apps which do not use modern security standards (mentioned on their support page). You can however, turn on/off this safety feature by going to the link below:

Go to this link and select Turn On

https://www.google.com/settings/security/lesssecureapps

Moreover google block an ip when you try to send a email since a unusual location, so, you can unblock in the next link

https://support.google.com/accounts/answer/6009563

and clicked in

accounts.google.com/DisplayUnlockCaptcha .

liftman
Posts: 4
Joined: Mon Jun 18, 2018 3:35 pm

Re: Gmail SMTP Setup Error

Postby liftman » Wed Jan 23, 2019 3:46 pm

The link in Melvin's reply for gmail specific in not working.

liftman
Posts: 4
Joined: Mon Jun 18, 2018 3:35 pm

Re: Gmail SMTP Setup Error

Postby liftman » Wed Jan 23, 2019 3:56 pm

Melvin wrote:Hello emrekacan,

Please take a look at the suggestions on the below thread. Those settings are important specifically for Gmail.

https://amcrest.com/forum/post1601.html ... ec75#p1601



This link does not work.

markfilan
Posts: 1
Joined: Tue Jul 30, 2019 1:00 am

Re: Gmail SMTP Setup Error

Postby markfilan » Tue Jul 30, 2019 1:02 am

Try Less secure apps configuration

Log in to your Gmail account through a web browser and enable access through less secure apps . Less secure apps can make your account more vulnerable, Google will automatically turn this setting off if it's not being used. However, bypass this security setting with a configuration tweak within your Google Email Account .

How "more secure apps" help to protect your account?

Which level of access you're giving the client before you connect your Account.
Client access only a relevant part of your Account, like your email or calendar.
Connect your Google Account to the client without exposing your password.
Disconnect your Google Account from the client at any time.


Return to “IP Cameras”

Who is online

Users browsing this forum: No registered users and 10 guests