Emails stopped working...

Have some questions or having issues with your IP Camera(s), Post them here for the mods and other users to assist you with.
plusfour
Posts: 51
Joined: Tue Mar 06, 2018 4:04 am

Re: Emails stopped working...

Postby plusfour » Tue Jun 18, 2019 11:34 pm

GRSmith wrote:What triggers that in both cases is the Client Hello packet from the camera. The attachment shows a side-by-side comparison of that Client Hello packet for TLS(587) and SSL(465). As you can see, they are identical.


Could you post an expanded version of the client random, and all the suites?

Also, why is the camera using the heartbeat extension? Does it have heartbleed?

plusfour
Posts: 51
Joined: Tue Mar 06, 2018 4:04 am

Re: Emails stopped working...

Postby plusfour » Tue Jun 18, 2019 11:39 pm

GRSmith wrote:I was curious to compare the failing Client Hello from the camera with a working Client Hello from my local email relay server to GMail. See attachment.


Ah, just what I'd been asking for, thanks! You've highlighted the problem, the client is incorrectly sending an SCSV indicator when there hasn't been a fallback. The fix is unrelated to TLS 1.3, Amcrest needs to remove the erroneous SCSV suite, see this for details.

Also, disable Heartbeat, I don't know why that's been enabled. And provide full error information, not just "failed", in the UI.

mromamcrest
Posts: 47
Joined: Mon Apr 22, 2019 9:55 am

Re: Emails stopped working...

Postby mromamcrest » Wed Jun 26, 2019 5:10 pm

A fix has been found by our R&D team. Below is the URL to the forum post to test the beta firmware for the following models. Other models will follow and will update this post as they become available to the team.

If you are interested in testing this firmware, please follow the link below.

for IP8M-2493E, IP8M-2496E, and IP8M-T2499E only:

https://amcrest.com/forum/ip-cameras-f1 ... 12593.html

Thank you for everyone's feedback while our R&D team worked diligently on this.

Please provide any feedback on this firmware on the topic at the provided link above.

Kalvin
Posts: 7
Joined: Wed Sep 28, 2016 7:16 pm

Re: Emails stopped working...

Postby Kalvin » Thu Jun 27, 2019 12:55 pm

Hi,

Any time line on a firmware for the IPM-723B cameras?

Thank you

mromamcrest
Posts: 47
Joined: Mon Apr 22, 2019 9:55 am

Re: Emails stopped working...

Postby mromamcrest » Thu Jun 27, 2019 6:59 pm

Kalvin wrote:Hi,

Any time line on a firmware for the IPM-723B cameras?

Thank you



Unfortunately, we currently do not have any firm timeline on the other models.


Other models will follow and we will update this post as they become available to the team.


Thank you for your patience and interest in our beta test.

plusfour
Posts: 51
Joined: Tue Mar 06, 2018 4:04 am

Re: Emails stopped working...

Postby plusfour » Fri Jun 28, 2019 12:16 am

Also, what about NVRs? I'm sending emails from an NVR, which is affected by the same problem.

mromamcrest
Posts: 47
Joined: Mon Apr 22, 2019 9:55 am

Re: Emails stopped working...

Postby mromamcrest » Fri Jun 28, 2019 12:53 pm

plusfour wrote:Also, what about NVRs? I'm sending emails from an NVR, which is affected by the same problem.



Same would apply, as we are provided with beta test firmware, we will update this thread and also include in the DVR/NVR forums as well.

Kalvin
Posts: 7
Joined: Wed Sep 28, 2016 7:16 pm

Re: Emails stopped working...

Postby Kalvin » Fri Jun 28, 2019 9:23 pm

mromamcrest, Thank you for taking the time to reply. I will keep an eye here for updates.

For the others interested, I used the Zoho.com email mentioned earlier in this thread and it is presently working for me. Might be a temp solution until the new firmware is released.

aminco
Posts: 2
Joined: Tue Jun 11, 2019 7:15 pm

Re: Emails stopped working...

Postby aminco » Wed Jul 03, 2019 11:43 am

Any updates on new firmware for other cameras, like the C841's?

megamawax
Posts: 2
Joined: Wed Jul 03, 2019 9:54 pm

Re: Emails stopped working...

Postby megamawax » Wed Jul 03, 2019 9:58 pm

I had Yahoo working for a short bit, but now that no longer works. I can't imagine ever buying another Amcrest camera. I have a Reolink, and emails work just fine with it. What good is a "security" camera if I can't get receive alerts?


Return to “IP Cameras”

Who is online

Users browsing this forum: Google [Bot] and 2 guests