Beta Test Firmware (841, 721, and HX1) 05/09/2019 ( OUTDATED)

All Beta tests that are current
Forum rules
Caution :!:
The Test Firmware listed below is only for the model(s) listed, using this firmware anywhere else will brick the device.
Test Firmware's have a Time Limit of eligibility and usability, once the Firmware is applied you have up to 6 Months to update to a Stable Firmware. Beta Firmware is NOT a stable release, we greatly appreciate help with the testing process. However, upgrading your device with beta testing firmware you will do so at Your Own Risk. If you run into any urgent issues and or having major issues, please send us an email [email protected]
User avatar
James.S
Site Admin
Posts: 135
Joined: Thu May 28, 2015 3:40 pm

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby James.S » Tue May 28, 2019 9:00 am

rskoey wrote:Just for peoples awareness. On a 721W I upgraded to the beta firmware, I also had HTTPS enabled, and after the upgrade the device kept rebooting/restarting/crashing (observed through PING monitoring). It would respond to pings for about a min or so, then stop responding for 20 - 30 seconds, and just keep repeating.

Factory reset, and device came up no problems with the correct new beta firmware, however I was able to reproduce the above symptoms by enabling HTTPS via the web interface.



I will be passing this information to our R&D team Thank you very much for your efforts in testing, What did you think over all?
Image
If you have any more questions or concerns about this product or other Amcrest products, please reach out to us at [email protected].

- James.S

CosmikDebris
Posts: 6
Joined: Wed May 15, 2019 4:51 pm

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby CosmikDebris » Thu May 30, 2019 9:31 am

An update to my earlier post. FTP is back to not working. I'm inclined to just buy a NAS and be done with trying.
"I might be moving to Montana soon."

User avatar
James.S
Site Admin
Posts: 135
Joined: Thu May 28, 2015 3:40 pm

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby James.S » Thu Jun 06, 2019 9:13 am

Thank you all once again for your help and information all the information we collect here goes directly to the Engineering Team.

Hope you all are doing well! :)
Image
If you have any more questions or concerns about this product or other Amcrest products, please reach out to us at [email protected].

- James.S

jon9314
Posts: 1
Joined: Sun Jun 09, 2019 5:39 am

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby jon9314 » Sun Jun 09, 2019 6:04 am

Does this beta update also contain the krack fix?

jmct123
Posts: 1
Joined: Tue Jun 18, 2019 6:26 pm

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby jmct123 » Tue Jun 18, 2019 6:41 pm

As best I can tell, this camera beta update still contains an older insecure version of OpenSSL - or at least a client that isn't correctly authenticating with mailservers and has incorrect TLS fallback logic. That's incompatible with Ubuntu and a growing number of Linux machines. In time, I'm assuming it will be widely incompatible with modern mailservers as larger organizations roll out this change.

Can you please update to a recent version in this release?

This is the error for TLS port 587 against recent Linux distros which are more common as of 2019:
postfix/smtpd[17599]: connect from ipcam-test[192.168.1.117]: -1
postfix/smtpd[17599]: warning: TLS library problem: error:14209175:SSL routines:tls_early_post_process_client_hello:i
nappropriate fallback:../ssl/statem/statem_srvr.c:1738:
postfix/smtpd[17599]: lost connection after STARTTLS from ipcam-test[192.168.1.117]
postfix/smtpd[17599]: disconnect from ipcam-test[192.168.1.117] ehlo=1 starttls=0/1 commands=1/2

For more details on the issue, see here:
https://security.stackexchange.com/questions/160922/ssl-error-inappropriate-fallback-and-tls-fallback-scsv
https://mta.openssl.org/pipermail/openssl-users/2017-June/005931.html

That said, great work on the JS embedded viewer - that's a much needed fix and really appreciated!

Thanks

Brien
Posts: 44
Joined: Tue Aug 25, 2015 2:39 pm

Re: Beta Test Firmware (841, 721, and HX1) 05/09/2019

Postby Brien » Thu Jun 20, 2019 2:48 pm

Which firmware is for the AMDV7204


Return to “Beta Testing Posts”

Who is online

Users browsing this forum: No registered users and 0 guests