corrupt and unplayable mp4 video file through FTP

Any major updates coming, Upcoming Software, General Security advice for others and topics alike Post them here so other users can chat with you.
quanbo
Posts: 2
Joined: Thu Jan 11, 2018 10:58 am

corrupt and unplayable mp4 video file through FTP

Postby quanbo » Thu Jan 11, 2018 11:17 am

If you use FTP to store your motion detection video of Amcrest camera, you may encounter big problem with some NAS product, such as WD my cloud.
When amcrest camera write video to FTP, it will use at least 5 user in same time to login to FTP server(check image below) . Some times camera will have write other temporary file which will login 6 or even more users in same time.
main admin login
write .mp4 file
write .idx file
write .bak file
write jpg file
The WD my cloud FTP function only allow 10 users at a time. So when WD my cloud dectect more than 10 users login, it will cut all login user. Which will cuase less than one second video file created.
Plz check below image, 6 users login at same time. Some times even more. If I set 10 max users in Filezilla, Filezilla will cut connection less than 1 second if 2 camera has motion detction at same time. So the mp4 is just serveral KB.
What amcrest need to do is in next fireware update just use one user to log in and write file on FTP. While other camera compay just use one user to log in so that WD my cloud can support up to 10 camera at the same time.
Image

longedge
Posts: 168
Joined: Fri Mar 31, 2017 9:34 am

Re: corrupt and unplayable mp4 video file through FTP

Postby longedge » Sat Jan 13, 2018 5:45 am

Just bye the bye - I found that by using ftp to connect to my WDMyCloudMirror NAS, I lost the first 5-8 seconds of the recordings no matter what I tried, using the NAS method to connect to the drive works perfectly on the other hand.
Using IP2M-841B (firmware 2.520.AC00.18.R).

Roy
Posts: 13
Joined: Sat Mar 24, 2018 8:52 pm

Re: corrupt and unplayable mp4 video file through FTP

Postby Roy » Wed Mar 28, 2018 6:16 am

Longedge, would you please tell me how you configured your WD Mycloud mirror to record from your amcrest cameras. I've been able to do so on my WD Mycloud ( single drive ) but not WD Mirror. I'm using ftp with password access and also read and write setting are on.

longedge
Posts: 168
Joined: Fri Mar 31, 2017 9:34 am

Re: corrupt and unplayable mp4 video file through FTP

Postby longedge » Wed Mar 28, 2018 7:19 am

Everything on my network is connected by ethernet (I gave up on Wi-Fi). My NAS and cameras are all configured with static IP's that are reserved on my router for those devices. In the NAS settings, I have a share that I use exclusively for the cameras and NFS is enabled for that share. In the camera settings I specify 1. The IP address and 2. The remote directory. The important part of that is to precede the remote directory with " /nfs/ " so it reads "/nfs/sharename ". In the web page for my NAS, when you enable NFS, then it gives you the network address calling it a "mount point".

I didn't have any problems at all setting ftp access up but I was never able to resolve losing the first part of every recording and so forgot about that in favour of NFS access which works without any loss at all.
Using IP2M-841B (firmware 2.520.AC00.18.R).

Roy
Posts: 13
Joined: Sat Mar 24, 2018 8:52 pm

Re: corrupt and unplayable mp4 video file through FTP

Postby Roy » Sun Apr 15, 2018 7:06 am

OMG, You're a lifesaver. Your suggested settings worked. I was racking my brain over this problem. Thanks a million.


Return to “General Security Chat”

Who is online

Users browsing this forum: No registered users and 1 guest