push notifications not working on android

Have some questions or having issues with Amcrest View Pro, Post them here for the mods and other users to assist you.
Systemuser
Posts: 19
Joined: Sun Jan 27, 2019 4:12 pm

Re: push notifications not working on android

Postby Systemuser » Fri Feb 22, 2019 3:11 pm

Still not found a solution just things that could be related. Saved the network packet capture from the NVR while making motion on camera that would normally send push notifications. Had to install Wireshark and it's 2 other included programs in order to read network traffic and some packet info off of NVR. I later uninstalled everything when our network slowed to a crawl around 1.5MB per second. Might not have been caused by those programs but also all the router logging, various port forwarding, changes to router, Installing required browser plugins, had 3 installed.

When my NVR makes the outgoing connection to firebase -> fcm.googleapis.com which usually shows as 172.217.X.X range. Messages going out from my NVR usually transmit OK except a for a couple reset requests to start sending them again.

When firebase -> fcm.googleapis.com tries to make an incoming connection to my NVR, it appears that firebase wants to connect to my NVR using TLS v1.2 and my NVR is not able to match that for the incoming connection.
Every few IP packets received from Firebase server say Alert (Level: Fatal, Description: Inappropriate Fallback) which repeats every few packets I read a server certificate is needed to allow TLS v1.2 connections to be made. So I tried the create your own certificate option that is included with the NVR and also tried it on a camera. On NV4108-HS a browser plugin is required to access the area to create your own certificate and install it, except NVR does not have a spot to put your email address or use a third party certificate like cameras do. Tried creating all 3 certificate types, one with my custom Amcrest DDNS name. then again my private IP 192.168.X.X, then again created a certificate to my public facing IP. Did not make any difference still saw these errors when Firebase tries to make incoming connections to my NVR. Not sure if TLS v1.2 can be accomplished on the hardware chips in future or in the software like in a NVR OS update? Tested it with UPnP enabled and P2P used on NVR, and also enabled port forwarding 443 to NVR but did not make any difference. IE and Chrome don't like the self created certificates either and both say invalid because it's self signed. I guess signed certificates are real expensive to buy and not sure if that would solve that problem anyhow.

The NVR makes like a thousand network connections and packet transfers in a few minutes of packet capture. Firebase messaging incoming to my NVR was the only connection with this type of error. Alert (Level: Fatal, Description: Inappropriate Fallback). which repeats every few packets or so. So I looked up TLS v1.2 and see that more of the big software companies like Google, Microsoft, Banks, card processors, are making connection with TLSv 1.2 mandatory. I am not sure how much of a problem it could be causing with incoming Firebase connections or just giving a warning that TLS v1.2 can not be made and the fallback method needs to be fixed. Is it possible Google Firebase might have just recently made TLS v1.2 mandatory when they connect out to individual servers? Also wonder if the data is transferred successfully when Firebase tries to connect even though it gives that message? The data in the exchanges between them do look encrypted. Also see in picture below that Firebases is using their 443 port to try to connect to my 55712-55719 port even though those were not forwarded. Rather than trying to connect to my 443 port. The connections in the picture below are all sorted by the firebase server incoming IP address to my NVR and is why they are all shown together in picture.

Then searched Firebase for TLS and see some results regarding TLS but could not tell if required when Firebase connects out to individual application server or not.
https://firebase.google.com/s/results/?q=TLS&p=%2F
Have screen capture pictures.
Attachments
TLSv1-2err.jpg
TLSv1-2err.jpg (148.98 KiB) Viewed 363 times
Last edited by Systemuser on Sun Feb 24, 2019 4:22 pm, edited 5 times in total.

Systemuser
Posts: 19
Joined: Sun Jan 27, 2019 4:12 pm

Re: push notifications not working on android

Postby Systemuser » Fri Feb 22, 2019 3:56 pm

One more thing I found on the web that might be affecting the phones ability to retrieve messages from the Firbase Messaging Service or the messanging service to contact the phone could be this if legit.

Some of the Main DNS service providers have made major changes in late January and early February. Filtering more stuff out, which is causing some web sites, servers or DNS to be unreachable. Possible our phone has lost it's ability to find the IP address for notifications or vice versa? I do not know what DNS Firebase and phones connect to but in the links below they mention problem going on at Akamai and other places websites not reachable.

I tried out some alternate DNS addresses into my NVR and router to see if it made any difference and did not. Not sure how the relay is supposed to work between firebase and the phones and if it depends on doing a DNS lookup before sending.

Here is a discussion of it on a Google Forum
https://groups.google.com/forum/#!forum/public-dns-discuss

Web page about these Flag Day changes around Feb 1st 2019, which could lead to sites unreachable.
https://dnsflagday.net/#resolver-ops

Another forum for flag day
https://groups.google.com/forum/#!forum/public-dns-announce

JonLandon
Posts: 3
Joined: Sun Dec 31, 2017 4:54 pm

Re: push notifications not working on android

Postby JonLandon » Sat Feb 23, 2019 9:27 pm

Push notifications stopped. Tried with two different NVR's and an Android S5 and an S9. They asked where I bought and model #, but they know it's the app. Said they'd let me know when fixed but taking way too long. It's programming? Fire your programmers or hire new. Don't like being politely told to buzz off. At least make available the older version of the app that did work! Gotta be a lot of dissatisfied customers who will buy something else because a home security cam you can't get notifications from when away from him is useless.

Systemuser
Posts: 19
Joined: Sun Jan 27, 2019 4:12 pm

Re: push notifications not working on android

Postby Systemuser » Fri Mar 01, 2019 5:17 pm

Push notifications still not working. Except a short term burst, did receive push notifications temporarily which only lasted around 14 minutes Feb 28th starting at 10:29PM and lasting until 10:44PM PST then they stopped again. And still next day not working again.

fil50
Posts: 14
Joined: Thu Jan 24, 2019 1:16 pm

Re: push notifications not working on android

Postby fil50 » Sat Mar 02, 2019 4:25 pm

Still nothing here!!!!!
wtf!!!

drdunga
Posts: 2
Joined: Fri Oct 14, 2016 7:27 am

Re: push notifications not working on android

Postby drdunga » Sun Mar 03, 2019 6:39 am

No notifications since early Feb here too, ugh.

User avatar
James.S
Site Admin
Posts: 133
Joined: Thu May 28, 2015 3:40 pm
Location: Houston, TX

Re: push notifications not working on android

Postby James.S » Tue Mar 05, 2019 3:05 pm

Hello All,


Just wanted to provide an update, we are still investigating this issue and collecting as much information as possible on this. If you have not already done so I highly encourage you to send us an email ([email protected]) about the push notification issues you are having so the Support Team or Myself can collect some information regarding your situation as well as send you updates when we receive them from the R&D/Engineering Teams.

Thank you all for your patience and we look forward to working with you and getting you back up and running.
Image
If you have any more questions or concerns about this product or other Amcrest products, please reach out to us at [email protected].

- James.S

paris1028
Posts: 2
Joined: Fri Mar 08, 2019 2:16 pm

Re: push notifications not working on android

Postby paris1028 » Fri Mar 08, 2019 2:20 pm

Multiple Amcrest devices including IP2M-841 and IPM-723B not getting push notifications (for motion detection). Has been down since Jan 23rd except for a few random moments. This is also across a number of android devices. What is Amcrest doing to solve this issue and when can we expect a fix? I have already replaced one of my Amcrest cameras with a different brand and will have to consider the same with the others if this issue isn't resolved soon. Really defeats the purpose of a security cam!

User avatar
James.S
Site Admin
Posts: 133
Joined: Thu May 28, 2015 3:40 pm
Location: Houston, TX

Re: push notifications not working on android

Postby James.S » Fri Mar 08, 2019 2:37 pm

paris1028 wrote:Multiple Amcrest devices including IP2M-841 and IPM-723B not getting push notifications (for motion detection). Has been down since Jan 23rd except for a few random moments. This is also across a number of android devices. What is Amcrest doing to solve this issue and when can we expect a fix? I have already replaced one of my Amcrest cameras with a different brand and will have to consider the same with the others if this issue isn't resolved soon. Really defeats the purpose of a security cam!



We are investigating what could be causing this and collecting information from customers as to possible to locate the issue. We are having a hard time replicating the issue 100% within our office. As stated in my previous reply, If you have not done so already, Please reach out to us so we can collect the information needed. we have also been able to assist many customers who were not particularly affected by this issue and something else was causing notification issues.

You can reach out to us here>[email protected]< We would be happy to work with you directly.
Image
If you have any more questions or concerns about this product or other Amcrest products, please reach out to us at [email protected].

- James.S

Mdias917
Posts: 1
Joined: Sat Mar 09, 2019 10:41 am

Re: push notifications not working on android

Postby Mdias917 » Sat Mar 09, 2019 10:48 am

Im having the same problem as everyone else. I just recently switched to the galaxy s10 from the iphone X and my push notifications completely stopped. I completely reset my nvr and started it up like new and still nothing. I set up everything on my s10 as i did on my iphone X. I tryed going back to my iphone X to see if android or my s10 was the problem and now i cant get push notifications to work on my iphone 10 either. I think its an issue of having multiple phones confuses the system maybe?


Return to “Amcrest View Pro”

Who is online

Users browsing this forum: No registered users and 1 guest